Monday 13 June 2011

Packet Tracer 5.3 Network

Lab 2 - Switch interfaces configuration 

Lab instructions

This lab will test your ability to configure speed, duplex, and vlan settings on a cisco switch interfaces.
1. Connect to Switch0 using console interface and configure each Switch0 fastethernet switchport for operation. Correct settings are :
- Port type : access port
- Speed : 100 Mbit/s
- Duplex mode : Full Duplex
- Autonegotiation disabled

2. PC "192.168.1.4" seems to be unable to ping other PCs in the network. Check switch configuration.
TIP : How many broadcast domains are there in this network ?

3. Choose the right cable to connect :
- Switch0 gigabitethernet 1/1 to Switch1 gigabitethernet 1/1
- Switch1 gigabitethernet 1/2 to Switch2 gigabitethernet 1/2

4. Configure those two links as trunk lines without using trunk negotiation between switches

Network diagram

 


Solution

Connect to Switch0 using console interface and configure each Switch0 fastethernet switchport for operation.
Switch(config)#interface FastEthernet0/1
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/2
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/3
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/4
switchport mode access
duplex full
speed 100

PC "192.168.1.4" seems to be unable to ping other PCs in the network. Check switch configuration.
Switch(config)#interface FastEthernet0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1


Choose the right cable to connect :
- Switch0 gigabitethernet 1/1 to Switch1 gigabitethernet 1/1
- Switch1 gigabitethernet 1/2 to Switch2 gigabitethernet 1/2



 

Configure those two links as trunk lines without using trunk negotiation between switches
On every interface that has to be configured for trunk operation, configure the following settings
Switch(config)#interface GigabitEthernet1/X
Switch(config-if)#switchport mode trunk

Verify interface operational mode using the "show interface GigabitEthernet1/X switchport command" :
Name: Gig1/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none

Another usefull ios command is "show interfaces trunk" :
Switch#sh interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Gig1/2      on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/2      1-1005

Port        Vlans allowed and active in management domain
Gig1/2      1

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/2      1

 

Packet Tracer 5.3 Network

Lab 1 - Basic switch setup 

 Introduction

A new switch just purchased from Cisco contains no default configuration in it. You need to configure the switch with setup mode using the setup mode or from scratch using the command line interface (CLI) before connecting it in your network environment. As a Cisco certified technician, it is very important to know the basic Cisco switch configuration commands to improve the performances and the security of your internetwork.

Lab instructions

This lab will test your ability to configure basic settings on a cisco switch.

1. Use the local laptop connect to the switch console.

2. Configure Switch hostname as LOCAL-SWITCH

3. Configure the message of the day as "Unauthorized access is forbidden"

4. Configure the password for privileged mode access as "cisco". The password must be md5 encrypted

5. Configure password encryption on the switch using the global configuration command

6. Configure CONSOLE access with the following settings :
- Login enabled
- Password : ciscoconsole
- History size : 15 commands
- Timeout : 6'45''
- Synchronous logging

6. Configure TELNET access with the following settings :
- Login enabled
- Password : ciscotelnet
- History size : 15 commands
- Timeout : 8'20''
- Synchronous logging
7. Configure the IP address of the switch as 192.168.1.2/24 and it's default gateway IP (192.168.1.1).

8. Test telnet connectivity from the Remote Laptop using the telnet client.

Download Link : http://www.mediafire.com/?6zsqnjb4gn08c9s

Network diagram


 Solution

Configure Switch hostname as LOCAL-SWITCH
hostname LOCAL-SWITCH

Configure the message of the day as "Unauthorized access is forbidden"
banner motd #
Unauthorized access is forbidden#

Configure the password for privileged mode access as "cisco". The password must be md5 encrypted
enable secret cisco

Configure password encryption on the switch using the global configuration command
service password-encryption

Configure CONSOLE access [...]
line con 0
password ciscoconsole
logging synchronous
login
history size 15
exec-timeout 6 45

Configure TELNET access [...]
line vty 0 15
exec-timeout 8 20
password ciscotelnet
logging synchronous
login
history size 15

Configure the IP address of the switch as 192.168.1.2/24 and it's default gateway IP (192.168.1.1).
interface Vlan1
ip address 192.168.1.2 255.255.255.0
       ip default-gateway 192.168.1.1

Sunday 12 June 2011

CorrectExams Oracle 1Z0-031 Exam Study Guide v1-2003 pdf

Coriolis - Solaris 8 System Administrator Exam Cram pdf

Coriolis - Open Source Development With CVS pdf

Core_Python_Programming[Wesley J. Chun](Prentice Hall PTR) pdf

Clustering with Tomcat pdf

Building Internet Firewalls - O Reilly zip

Boson CCNA 640-801 pdf

APress - The Definitive Guide to MySQL, 2nd Ed - 2004 - (By Laxxuss) chm

Apache Jakarta Tomcat 2 (APress) pdf

Apache based WebDAV with LDAP and SSL HOWTO3.pdf

AIX Reference for Sun Solaris Administrators pdf

Advanced_Python_programming pdf

Advanced Linux Programming pdf

Administracion Tomcat pdf

Addison.Wesley.Advanced.Linux.Networking chm

Addison.Wesley.A.Programmers.Guide.To.Java.Certification.2nd.Edition.eBook-LiB chm

Addison Wesley - UNIX.Network.Programming.Volume.1.3rd.Ed.The.Sockets.Networking.API-LiB chm

Addison Wesley - Tcl and The Tk Toolkit pdf

Addison Wesley - Sendmail Performance Tuning chm

Addison Wesley - PostgreSQL - Introduction and Concepts pdf

Addison Wesley - Perl To Python Migration - 2001 - (By Laxxuss) chm

Addison Wesley - Multitool Linux - Practical Uses For Open Source Software rar

Addison Wesley - Learn to Program Using Python 1st edtion zip

Addison Wesley - Firewalls and Internet Security rar

Absolute.OpenBSD.UNIX.For.The.Practical.Paranoid.eBook-LiB chm

A_Buffer_Overflow_Study_-_Attacks_and_Defenses_(2002) pdf

0201702452_The Design and Implementation of the FreeBSD Operating System chm

100_LINUX_TIPS_AND_TRICKS PDF

Learning Wireless Java rar

Java Performance Tuning pdf

Jakarta Struts pdf

Core JSP.pdf

David Mertz - Text Processing In Python zip

Slackware Linux Essentials zip

Linux kernal 2.4 Internals pdf

J2Me In A Nutshell - Decrypted pdf

O'Reilly - Java NIO pdf

SAMS - Slackware Linux Unleashed - Kamran Hus zip

O'Reilly Learning the Unix OS zip

O'REILLY Practical UNIX and Internet Security zip

O'Reilly.CGI.Programming pdf

(ebook.-.html).RHCE.Syngress.Red.Hat.Certified.Engineer.Study.Guide.2nd.ed.Ebook.Only.nothingyoud rar

SAMS - DB2 Developer's Guide-Fourth Edition pdf

Friday 10 June 2011

Sun - Solaris 9 SysAd Guide - Advanced pdf

Redhat Linux Rhce Cramsession pdf

O'Reilly Learning Perl pdf

O'Reilly - sendmail Desktop Reference pdf

O'Reilly - PHP Cookbook PDF

Linux Command Directory pdf

Java 3d Programming pdf

JavaServer Pages - Examples (O'Reilly) zip

Slackware Linux Unleashed, Third Edition zip

O'Reilly - Advanced Perl Programming pdf

Html - Linux Configuration & Installation (Slackware) zip

Biology O'Reilly Beginning Perl for Bioinformat zip

Zope and MySQL pdf

UNIX Programmer's Manual pdf

UNIX Cook Book pdf

Solaris Kernel Tuning for Security pdf

Programming Linux Games pdf

(ebook - PDF) JBoss Server Development with Eclipse pdf

(ebook - PDF) JBoss Group - JBoss All Docs Subscription zip

(ebook - pdf) Hack Proofing Linux pdf

(ebook - HTML) JBoss and PostgreSQL rar

(ebook - HTML - Python) O'Reilly - Core Python rar

(ebook - chm) - Misc - Debian The Perfect Setup chm

CISCO CCNA BOOKS

Click the below link to get download the CISCO CCNA BOOKs
www.instylebook.blogspot.com

Using hostnames in IP access lists

When I was configuring the access list that should prevent spammers from misusing my workstations, I obviously had to figure out the IP address of the ISP’s SMTP server (access lists and object groups accept IP addresses). I almost started nslookup on my Linux workstation, but then decided to try entering a hostname in an IOS ACL … and it works. Unfortunately, IOS performs a DNS lookup when you enter the hostname (assuming you have configured the ip name-server) and stores the resulting IP address in the ACL definition:

rtr(config)#ip access-list extended InsideList
rtr(config-ext-nacl)#permit tcp any host smtp.example.com eq smtp
Translating "smtp.example.com"...domain server (192.168.0.1) [OK]
rtr(config-ext-nacl)#do show access-list InsideList
Extended IP access list InsideList
    10 permit tcp any host 192.168.2.3 eq smtp

You can enter hostnames in ACLs or network object groups. In both cases, the name is immediately translated into an IP address.

Last-resort password recovery

                         An interesting password recovery technique, which can be used in those weird circumstances when you cannot force the router to go to ROMMON (for example, you’ve configured no service password-recovery and the break signal does not work as expected). Unfortunately, his trick works only if you can remove the flash memory from the router (it’s soldered in low-end models):

   1. Turn off the router.
   2. Take out the flash.
   3. Turn on the router.
   4. This time router will take you to ROMMON as it cannot find an IOS image.
   5. Set the configuration register with confreg 0x2142.
   6. Reset (this will change the stored value of the configuration register).
   7. Turn off the router.
   8. Reinsert the flash.
   9. Turn on the router and you are done.